When I updated to Windows 8.1, I noticed all of a sudden I lost my external USB drives.  What happened was all of the USB 3.0 ports stopped working.   Looking into it, it turns out that it is an issue with the drivers that are automatically installed with the ASUS Z77.   I tried uninstalling/reinstalling the ASUS AI Suite II, but that didn't seem to help.   Here's what I ended up doing to resolve the issue.

1. Open up the Device Manager in Control Panel
2. Open up the Universal Serial Bus controllers section
3. Right-click and uninstall the ASMedia USB 3.0 eXtensible Host Controllers
4. Right-click and uninstall the Intel USB 3.0 eXtensible Host Controllers
5. Uninstall the ASUS AI Suite II
6. Reboot the computer

When the computer came back up, everything worked fine.  The ASMedia and Intel USB 3.0 eXtensible Host Controllers that were uninstalled before the reboot were automatically reinstalled.   There's really no need to reinstall the AI Suite II, although I guess you could if you wanted to (I don't really care about that utility as long as my USB ports work).

Hope that helps someone who might've run into similar issues!

Leave a Reply

Your email address will not be published. Required fields are marked *